summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-11-13 12:46:04 -0600
committerAndreas Enge <andreas@enge.fr>2014-11-18 23:10:26 +0100
commit93882f0edaf69d3ae04cdc9f0100e97248f99b91 (patch)
tree9019839447f4e1d491acc56aab8c9b153ff2326a
parent3f2a772789bacb4c1c5cdbddb1699ba8152a9cc8 (diff)
downloadguix-93882f0edaf69d3ae04cdc9f0100e97248f99b91.tar.gz
gnu: intltool: Make file a regular input.
* gnu/packages/glib.scm (intltool)[propagated-inputs]: Move file from here...
  [inputs]: to here.
  [arguments]: New 'patch-file-references phase.
-rw-r--r--gnu/packages/glib.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index ac1b095836..e79be41d1a 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -250,16 +250,23 @@ bindings to call into the C library.")
               (base32
                "01j4yd7i84n9nk4ccs6yifg84pp68nr9by57jdbhj7dpdxf5rwk7"))))
     (build-system gnu-build-system)
+    (inputs
+     `(("file" ,file)))
     (propagated-inputs
      `(;; Propagate gettext because users expect it to be there, and so does
        ;; the `intltool-update' script.
        ("gettext" ,gnu-gettext)
 
-       ;; `file' is used by `intltool-update' too.
-       ("file" ,file)
-
        ("perl-xml-parser" ,perl-xml-parser)
        ("perl" ,perl)))
+    (arguments
+     `(#:phases (alist-cons-after
+                 'unpack 'patch-file-references
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   (let ((file (assoc-ref inputs "file")))
+                     (substitute* "intltool-update.in"
+                       (("`file") (string-append "`" file "/bin/file")))))
+                 %standard-phases)))
     (home-page "https://launchpad.net/intltool/+download")
     (synopsis "Tools to centralise translations of different file formats")
     (description