summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:09:50 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:53 -0400
commitab12bd3a0455d7081ad8c63eae8c3a90e75079c8 (patch)
tree2c418c580b39884a81b5ed02fabd468499cf4854
parentfe3c62c7d541abd8f77b9f216d087f8b8997c4df (diff)
downloadguix-ab12bd3a0455d7081ad8c63eae8c3a90e75079c8.tar.gz
gnu: Add ghc-tasty-th.
* gnu/packages/haskell.scm (ghc-tasty-th): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 544c21d245..cadf09784e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6641,4 +6641,29 @@ This is not good for Unicode users.  This modified regex-compat uses regex-tdfa
 this problem.")
     (license license:bsd-3)))
 
+(define-public ghc-tasty-th
+  (package
+    (name "ghc-tasty-th")
+    (version "0.1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/tasty-th/tasty-th-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "0dff9si8i1qp0s7p4hlk0l29vq7wxfglw6mvlgmld43h7rllv88q"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-tasty" ,ghc-tasty)))
+    (home-page "http://github.com/bennofs/tasty-th")
+    (synopsis "Automatically generate tasty TestTrees")
+    (description
+      "Tasty-th automatically generates tasty TestTrees from functions of the
+current module, using TemplateHaskell.  This is a fork the original
+test-framework-th package, modified to work with tasty instead of
+test-framework.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here