summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-08-03 18:37:18 +0200
committerLudovic Courtès <ludo@gnu.org>2016-08-03 18:37:18 +0200
commit134f657318b4013060358f0d64c7f9525fd4753b (patch)
tree1f48e4a4929977b68138ccd3629ba2a0fd88cc55
parent97b9da6897a5026da88de230c32844511f02b29c (diff)
parent80d944b79a795af325cd4b6d6734b60c5903ecdf (diff)
downloadguix-134f657318b4013060358f0d64c7f9525fd4753b.tar.gz
Merge branch 'version-0.11.0'
-rw-r--r--doc/guix.texi10
-rw-r--r--doc/htmlxref.cnf8
-rw-r--r--gnu/packages/linux.scm10
-rw-r--r--gnu/packages/package-management.scm18
4 files changed, 30 insertions, 16 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 27f10ba8f3..df8b5a9241 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -1241,7 +1241,7 @@ programs to authenticate Web servers accessed over HTTPS.
 
 When using Guix on a foreign distro, you can install this package and
 define the relevant environment variables so that packages know where to
-look for certificates.  @pxref{X.509 Certificates}, for detailed
+look for certificates.  @xref{X.509 Certificates}, for detailed
 information.
 
 @subsection Emacs Packages
@@ -7836,7 +7836,7 @@ gexps to introduce job definitions that are passed to mcron
   #~(job "5 0 * * *"            ;Vixie cron syntax
          "guix gc -F 1G"))
 
-(define idutils-jobs
+(define idutils-job
   ;; Update the index database as user "charlie" at 12:15PM
   ;; and 19:15PM.  This runs from the user's home directory.
   #~(job '(next-minute-from (next-hour '(12 19)) '(15))
@@ -7861,8 +7861,8 @@ list of gexps denoting mcron job specifications.
 
 This is a shorthand for:
 @example
-  (service mcron-service-type
-           (mcron-configuration (mcron mcron) (jobs jobs)))
+(service mcron-service-type
+         (mcron-configuration (mcron mcron) (jobs jobs)))
 @end example
 @end deffn
 
@@ -7872,7 +7872,7 @@ This is the type of the @code{mcron} service, whose value is an
 
 This service type can be the target of a service extension that provides
 it additional job specifications (@pxref{Service Composition}).  In
-other words, it is possible to define services that provide addition
+other words, it is possible to define services that provide additional
 mcron jobs to run.
 @end defvr
 
diff --git a/doc/htmlxref.cnf b/doc/htmlxref.cnf
index 559cdce5aa..bd2eb5f147 100644
--- a/doc/htmlxref.cnf
+++ b/doc/htmlxref.cnf
@@ -1,7 +1,7 @@
 # htmlxref.cnf - reference file for free Texinfo manuals on the web.
 # Modified by Ludovic Courtès <ludo@gnu.org> for the GNU Guix manual.
 
-htmlxrefversion=2016-03-30.07; # UTC
+htmlxrefversion=2016-08-03.13; # UTC
 
 # Copyright 2010, 2011, 2012, 2013, 2014, 2015 Free Software Foundation, Inc.
 # 
@@ -224,6 +224,9 @@ emacs-muse	node	${GS}/emacs-muse/manual/html_node/
 
 emms		node	${GS}/emms/manual/
 
+# The file is called 'find.info' but the package is 'findutils'.
+find		mono	${GS}/findutils/manual/html_mono/find.html
+find		node	${GS}/findutils/manual/html_node/find_html
 findutils	mono	${GS}/findutils/manual/html_mono/find.html
 findutils	node	${GS}/findutils/manual/html_node/find_html
 
@@ -468,6 +471,9 @@ mailutils	node	${GS}/mailutils/manual/html_node/
 make		mono	${GS}/make/manual/make.html
 make		node	${GS}/make/manual/html_node/
 
+mcron		mono	${GS}/mcron/manual/mcron.html
+mcron		node	${GS}/mcron/manual/html_node/
+
 mdk		mono	${GS}/mdk/manual/mdk.html
 mdk		node	${GS}/mdk/manual/html_node/
 
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e65327c61d..f6352da486 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2363,7 +2363,15 @@ MPEG-2 and audio over Linux IEEE 1394.")
                      (substitute* "udev-md-raid-arrays.rules"
                        (("/usr/bin/(readlink|basename)" all program)
                         (string-append coreutils "/bin/" program)))))
-                 (alist-delete 'configure %standard-phases))
+                 (alist-cons-before
+                  'build 'remove-W-error
+                  (lambda _
+                    ;; We cannot build with -Werror on i686 due to a
+                    ;; 'sign-compare' warning in util.c.
+                    (substitute* "Makefile"
+                      (("-Werror") ""))
+                    #t)
+                  (alist-delete 'configure %standard-phases)))
        ;;tests must be done as root
        #:tests? #f))
     (home-page "http://neil.brown.name/blog/mdadm")
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 5b8aabd05b..1421c7ea0a 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -67,17 +67,17 @@
                      arch "-linux"
                      "/20131110/guile-2.0.9.tar.xz")))
 
-(define-public guix-0.10.0
+(define-public guix-0.11.0
   (package
     (name "guix")
-    (version "0.10.0")
+    (version "0.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "ftp://alpha.gnu.org/gnu/guix/guix-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "0d4afwy7bpqi4k4bzvwc4ga4shwssis1nrvdw53qjyg9bw1a8lbn"))))
+               "1cwrbpv4dq7aczwksmcfw9w8r2bzrb5ld9zvjcr90i804hjpcb93"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags (list
@@ -212,9 +212,9 @@ the Nix package manager.")
   ;;
   ;; Note: use a very short commit id; with a longer one, the limit on
   ;; hash-bang lines would be exceeded while running the tests.
-  (let ((commit "97c8aef15de89799ac01b62dd9b91245c23eefcb"))
-    (package (inherit guix-0.10.0)
-      (version (string-append "0.10.0-1." (string-take commit 4)))
+  (let ((commit "4420940f20a2f36f29519f686bca7b85be6be5c9"))
+    (package (inherit guix-0.11.0)
+      (version (string-append "0.11.0-1." (string-take commit 4)))
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
@@ -224,10 +224,10 @@ the Nix package manager.")
                       (commit commit)))
                 (sha256
                  (base32
-                  "0sdxq87mbvig7785gzf52ywmvl3p1q1qgsczmkzrlw988xkma1dr"))
+                  "1c1rqsfc4vrclkk03aj1m8r1lzk9pfa61ax9hhhj5nw23bilsixc"))
                 (file-name (string-append "guix-" version "-checkout"))))
       (arguments
-       (substitute-keyword-arguments (package-arguments guix-0.10.0)
+       (substitute-keyword-arguments (package-arguments guix-0.11.0)
          ((#:configure-flags flags)
           ;; Set 'DOT_USER_PROGRAM' to the empty string so we don't keep a
           ;; reference to Graphviz, whose closure is pretty big (too big for
@@ -251,7 +251,7 @@ the Nix package manager.")
          ("texinfo" ,texinfo)
          ("graphviz" ,graphviz)
          ("help2man" ,help2man)
-         ,@(package-native-inputs guix-0.10.0))))))
+         ,@(package-native-inputs guix-0.11.0))))))
 
 (define-public guix guix-devel)