summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre-Antoine Rault <par@rigelk.eu>2015-02-04 01:02:20 +0100
committerMark H Weaver <mhw@netris.org>2015-02-04 01:36:03 -0500
commitd95a56c6329f6e02cd8e80af482c326d5edc849f (patch)
tree2f4022998fff03bd752eb67c12b3dc1aea4b20bc
parent613467abc5bd3a7634fe37d6ab5dd86dd0d54a16 (diff)
downloadguix-d95a56c6329f6e02cd8e80af482c326d5edc849f.tar.gz
gnu: Add python-dbus.
* gnu/packages/python.scm (python-dbus): Add it. Makes use of dbus,
  dbus-glib and glib itself.
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ec0c16620f..fc10926b84 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6,6 +6,7 @@
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
 ;;; Copyright © 2015 Omar Radwan <toxemicsquire4@gmail.com>
+;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -55,6 +56,7 @@
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
+  #:use-module (gnu packages pkg-config)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -2874,3 +2876,29 @@ features useful for text console applications.")
 
 (define-public python2-urwid
   (package-with-python2 python-urwid))
+
+(define-public python-dbus
+  (package
+    (name "python-dbus")
+    (version "1.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "1py62qir966lvdkngg0v8k1khsqxwk5m4s8nflpk1agk5f5nqb71"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("python" ,python)
+       ("dbus" ,dbus)
+       ("dbus-glib" ,dbus-glib)
+       ("glib" ,glib)))
+    (synopsis "Python bindings for D-bus")
+    (description "python-dbus provides bindings for libdbus, the reference
+implementation of D-Bus.")
+    (home-page "http://www.freedesktop.org/wiki/Software/DBusBindings/")
+    (license expat)))