summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-03-20 03:52:13 -0400
committerMark H Weaver <mhw@netris.org>2014-03-20 05:08:23 -0400
commit12fa800d7e41e033eeffa1bb555a82b828321f03 (patch)
tree7ef656519177f6f3366f2c66c1534a6e1fdfd428
parentf6d47eb6d5e046abc8a7a7dc0863c5661197ef0d (diff)
downloadguix-12fa800d7e41e033eeffa1bb555a82b828321f03.tar.gz
gnu: util-macros: Install .pc file in lib/pkgconfig; remove INSTALL file.
* gnu/packages/xorg.scm (util-macros): Substitute "$(libdir)/pkgconfig"
  for "$(datadir)/pkgconfig" in Makefile.in.  After install, remove
  share/util-macros/INSTALL and share/util-macros.
-rw-r--r--gnu/packages/xorg.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index abcbfba88a..13da10d7cb 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1742,6 +1743,22 @@ tracking.")
             "1vbmrcn5n3wp4pyw0n4c3pyvzlc4yf7jzgngavfdq5zwfbgfsybx"))))
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)))
+    (arguments
+     `(#:phases (alist-cons-after
+                 'unpack 'fix-makefile-in
+                 (lambda _
+                   (substitute* "Makefile.in"
+                     ;; Install xorg-macros.pc in PREFIX/lib/pkgconfig,
+                     ;; not PREFIX/share/pkgconfig.
+                     (("\\$\\(datadir\\)/pkgconfig") "$(libdir)/pkgconfig")))
+                 (alist-cons-after
+                  'install 'post-install-cleanup
+                  (lambda* (#:key outputs #:allow-other-keys)
+                    (let ((out (assoc-ref outputs "out")))
+                      (with-directory-excursion out
+                        (delete-file "share/util-macros/INSTALL")
+                        (rmdir "share/util-macros"))))
+                  %standard-phases))))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")