summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-07-13 16:38:26 +0200
committerJohn Darrington <jmd@gnu.org>2014-07-16 06:28:01 +0200
commitb4ce630048e0c755897c35670560d7c0bb9ce044 (patch)
tree43c3c8cef5e093740230d76affb9ea85f93889dd
parent7f4bf030343bcb8a356f225595b0e2732025d311 (diff)
downloadguix-b4ce630048e0c755897c35670560d7c0bb9ce044.tar.gz
gnu: Enable gnome-doc-utils tests
* gnu/packages/gnome (gnome-doc-utils): Set the XML_CATALOG_FILES variable and
  enable the tests.
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a043d8d4d2..893c3e8a6b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -26,6 +26,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages flex)  
+  #:use-module (gnu packages docbook)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gstreamer)
@@ -136,14 +137,24 @@ The gnome-about program helps find which version of GNOME is installed.")
        (base32
         "19n4x25ndzngaciiyd8dd6s2mf9gv6nv3wv27ggns2smm7zkj1nb"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (alist-cons-before
+        'check 'pre-check
+        (lambda* (#:key inputs #:allow-other-keys #:rest args)
+          ;; This is needed, because without it, xmlint etc tries
+          ;; to download docbookx.dtd from the net
+          (setenv "XML_CATALOG_FILES" 
+                  (string-append (assoc-ref inputs "docbook-xml") 
+                                 "/xml/dtd/docbook/catalog.xml")))
+        %standard-phases)))
     (native-inputs
      `(("intltool" ,intltool)
+       ("docbook-xml" ,docbook-xml-4.4)
        ("libxml2" ,libxml2)
        ("libxslt" ,libxslt)
        ("pkg-config" ,pkg-config)
        ("python-2" ,python-2)))
-    (arguments
-     `(#:tests? #f)) ; tries to load http://www.oasis-open.org/docbook/xml/4.4/docbookx.dtd
     (home-page "https://wiki.gnome.org/GnomeDocUtils")
     (synopsis
      "Documentation utilities for the Gnome project")