summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-06-18 18:04:41 -0400
committerMark H Weaver <mhw@netris.org>2014-06-18 18:42:35 -0400
commit2c14c6d7cb51409bb2dff923cda3ac197bede5c6 (patch)
treeebe58b8b5c9b427ed5ce195db2443728c1fb71ec
parented4a8816d64ed3e84e61aa1e29866a86e25c72cc (diff)
downloadguix-2c14c6d7cb51409bb2dff923cda3ac197bede5c6.tar.gz
gnu: gawk: Apply work around to build system for MIPS.
* gnu/packages/gawk.scm (gawk): Work around a build problem on MIPS.
-rw-r--r--gnu/packages/gawk.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index fe422a2014..6185409fb7 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -54,6 +55,17 @@
                           '((substitute* "extension/Makefile.in"
                               (("^.*: check-for-shared-lib-support" match)
                                (string-append "### " match))))
+                          '())
+
+                    ;; XXX FIXME gawk 4.1.1 was bootstrapped with a prerelease
+                    ;; libtool, which fails on MIPS in the absence of
+                    ;; /usr/bin/file.  As a temporary workaround, we patch
+                    ;; the configure script to hardcode use of the little
+                    ;; endian N32 ABI on MIPS.
+                    ,@(if (equal? "mips64el-linux" (or (%current-target-system)
+                                                       (%current-system)))
+                          '((substitute* "extension/configure"
+                              (("\\$emul") "elf32ltsmipn32")))
                           '())))
                 %standard-phases)))
    (inputs `(("libsigsegv" ,libsigsegv)