summary refs log tree commit diff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-09-09 00:59:10 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-09-14 00:14:56 +0200
commit2713527e0694112a3970e22eac66dc938bea0463 (patch)
treea3ad9c5c1b1a64c4e992769f4c03ed026e69aacc
parent5e412b6383fbdceb971d940ecb534f187a59a443 (diff)
downloadguix-2713527e0694112a3970e22eac66dc938bea0463.tar.gz
gnu: Add python-debtcollector.
* gnu/packages/openstack.scm (python-debtcollector,
  python2-debtcollector): New variables.
-rw-r--r--gnu/packages/openstack.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 1f321bf312..c099846bac 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -25,6 +25,41 @@
                 #:select (asl2.0))
   #:use-module (guix packages))
 
+(define-public python-debtcollector
+  (package
+    (name "python-debtcollector")
+    (version "0.5.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://pypi.python.org/packages/source/d/debtcollector/"
+               "debtcollector-" version ".tar.gz"))
+        (sha256
+          (base32
+            "0amlcg5f98lk2mfzdg44slh1nsi2y4ds123g5d57376fjk2b3njd"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-six" ,python-six)
+       ("python-wrapt" ,python-wrapt)))
+    (inputs
+      `(("python-babel" ,python-babel)
+        ("python-pbr" ,python-pbr)
+        ("python-setuptools" ,python-setuptools)
+        ;; Tests.
+        ("python-oslotest" ,python-oslotest)))
+    (home-page "http://www.openstack.org/")
+    (synopsis
+      "Find deprecated patterns and strategies in Python code")
+    (description
+      "This package provides a collection of Python deprecation patterns and
+strategies that help you collect your technical debt in a non-destructive
+manner.")
+    (license asl2.0)))
+
+(define-public python2-debtcollector
+  (package-with-python2 python-debtcollector))
+
 (define-public python-mox3
   (package
     (name "python-mox3")