summary refs log tree commit diff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-09-14 22:53:32 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-09-16 22:53:36 +0200
commit2c9d96767a8ad616d61f0548b6ebba0b762589dd (patch)
treecb6f7ea2e63c3b38aae66f82f6df1ae0cd05d783
parentde34aface7e0c83b02c3def1ec55630e29bed6b7 (diff)
downloadguix-2c9d96767a8ad616d61f0548b6ebba0b762589dd.tar.gz
gnu: Add python-requests-mock.
* gnu/packages/openstack.scm (python-requests-mock,
  python2-requests-mock): New variables.
-rw-r--r--gnu/packages/openstack.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index a0e6952e2a..39584d566f 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -174,6 +174,37 @@ and sensible default behaviors into your setuptools run.")
 (define-public python2-pbr
   (package-with-python2 python-pbr))
 
+(define-public python-requests-mock
+  (package
+    (name "python-requests-mock")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/r/requests-mock/"
+             "requests-mock-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0gmd88c224y53b1ai8cfsrcxm9kw3gdqzysclmnaqspg7zjhxwd1"))))
+    (build-system python-build-system)
+    (propagated-inputs
+      `(("python-requests" ,python-requests)
+        ("python-six" ,python-six)))
+    (inputs
+      `(("python-mock" ,python-mock)
+        ("python-pbr" ,python-pbr)
+        ("python-setuptools" ,python-setuptools)))
+    (home-page "https://requests-mock.readthedocs.org/")
+    (synopsis "Mock out responses from the requests package")
+    (description
+      "This module provides a building block to stub out the HTTP requests
+portions of your testing code.")
+    (license asl2.0)))
+
+(define-public python2-requests-mock
+  (package-with-python2 python-requests-mock))
+
 (define-public python-stevedore
   (package
     (name "python-stevedore")