summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-14 06:25:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-22 01:06:02 +0100
commit2e3b1a92f4df656a0e678b6461d17d08db67e894 (patch)
tree05016ed427f443805fe7bbf2d8241cf4fb331432
parent5dca4c76ac02918546dae2300419d940571381d3 (diff)
downloadguix-2e3b1a92f4df656a0e678b6461d17d08db67e894.tar.gz
gnu: Add lzlib.
* gnu/packages/compression.scm (lzlib): New public variable.
-rw-r--r--gnu/packages/compression.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index be82296ae6..c27963162c 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1995,3 +1995,31 @@ in other applications like package managers.
 Clzip is intended to be fully compatible with the regular lzip package.")
     (license (list license:bsd-2        ; carg_parser.[ch], lzd in clzip.texi
                    license:gpl2+))))
+
+(define-public lzlib
+  (package
+    (name "lzlib")
+    (version "1.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://download.savannah.gnu.org/releases/lzip/"
+                           name "/" name "-" version ".tar.gz"))
+       (sha256
+        (base32 "13mssf3hrcnmd4ijbqnxfk0zgj1q5lvpxxkm1hmrbl1h73czhwi4"))))
+    (build-system gnu-build-system)
+    ;; The included minilzip binary is only ~16 smaller than the ‘real’ lzip.
+    ;; It's used during the test suite, but don't be tempted to install it.
+    (arguments
+     `(#:configure-flags
+       (list "CC=gcc"
+             "--enable-shared")))       ; only static (.a) is built by default
+    (home-page "http://www.nongnu.org/lzip/lzlib.html")
+    (synopsis "Lzip data compression C library")
+    (description
+     "Lzlib is a C library for in-memory LZMA compression and decompression in
+the lzip format.  It supports integrity checking of the decompressed data, and
+all functions are thread-safe.  The library should never crash, even in case of
+corrupted input.")
+    (license (list license:bsd-2        ; the library itself
+                   license:gpl2+))))    ; main.c (i.e. minilzip used by tests)