summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2017-01-04 18:53:03 +0100
committerDavid Craven <david@craven.ch>2017-01-04 19:10:00 +0100
commit337273e41f6bb9486424d0bb636e69f9ca55d88f (patch)
tree0a5b592758268aa3a6d51f260185f8e8fec29738
parent9c64f76e8af87348c5d0871a374213416237dafa (diff)
downloadguix-337273e41f6bb9486424d0bb636e69f9ca55d88f.tar.gz
gnu: ocaml-ounit: Enable tests.
Followup to 7a76b4afd0ce296bb462be8cf66234e41672c285.

* gnu/packages/ocaml.scm (ocaml-ounit)[arguments]: Enable tests.

Problem reported by Julien Lepiller <julien@lepiller.eu>.
-rw-r--r--gnu/packages/ocaml.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 25c0815786..4313bde8a8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -777,7 +777,10 @@ compilers that can directly deal with packages.")
     (native-inputs
      `(("libxml2" ,libxml2))) ; for xmllint
     (arguments
-     `(#:tests? #f)) ; tests are done during build
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; Tests are done during build.
+         (delete 'check))))
     (home-page "http://ounit.forge.ocamlcore.org")
     (synopsis "Unit testing framework for OCaml")
     (description "Unit testing framework for OCaml.  It is similar to JUnit and