summary refs log tree commit diff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-09-09 00:51:45 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-09-14 00:14:56 +0200
commit5e412b6383fbdceb971d940ecb534f187a59a443 (patch)
tree90780b43707bf5d3d6c69323415c86453cfad11a
parentb85c85becd36aa3abbd80dbb5b22705f10e5e57a (diff)
downloadguix-5e412b6383fbdceb971d940ecb534f187a59a443.tar.gz
gnu: Add python-monotonic.
* gnu/packages/python.scm (python-monotonic, python2-monotonic): New variables.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 85ab88c709..c58d7f3fc1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4826,3 +4826,30 @@ and MAC network addresses.")
 
 (define-public python2-iso8601
   (package-with-python2 python-iso8601))
+
+(define-public python-monotonic
+  (package
+    (name "python-monotonic")
+    (version "0.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://pypi.python.org/packages/source/m/monotonic/monotonic-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "0yz0bcbwx8r2c01czzfpbrxddynxyk9k95jj8h6sgcb7xmfvl998"))))
+    (build-system python-build-system)
+    (inputs
+      `(("python-setuptools" ,python-setuptools)))
+    (home-page "https://github.com/atdt/monotonic")
+    (synopsis "Implementation of time.monotonic() for Python 2 & < 3.3")
+    (description
+      "This module provides a monotonic() function which returns the value (in
+fractional seconds) of a clock which never goes backwards.")
+    (license asl2.0)))
+
+(define-public python2-monotonic
+  (package-with-python2 python-monotonic))