summary refs log tree commit diff
diff options
context:
space:
mode:
authorpjotr.public12@thebird.nl <pjotr.public12@thebird.nl>2015-09-15 16:48:35 +0200
committerDavid Thompson <dthompson2@worcester.edu>2015-09-15 14:37:09 -0400
commit62e4cc5aa19e4c64fc244e3c6724d8e4d97f8599 (patch)
tree52a75487a4efa5688a6013ad01c634ab47a12e73
parent3500e659f114e0e8213f2b8340128f66251bd7b4 (diff)
downloadguix-62e4cc5aa19e4c64fc244e3c6724d8e4d97f8599.tar.gz
gnu: Add ruby-gherkin3.
* gnu/packages/ruby.scm (ruby-gherkin3): New variable.
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ee0acc8639..7dc46b6caa 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1124,3 +1124,26 @@ it unifies the API for web servers, web frameworks, and software in between
 into a single method call.")
     (home-page "http://rack.github.io/")
     (license license:expat)))
+
+(define-public ruby-gherkin3
+  (package
+    (name "ruby-gherkin3")
+    (version "3.1.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (rubygems-uri "gherkin3" version))
+        (sha256
+          (base32
+            "0xsyxhqa1gwcxzvsdy4didaiq5vam8ma3fbwbw2w60via4k6r1z9"))))
+    (build-system ruby-build-system)
+    (native-inputs
+     `(("bundler" ,bundler)))
+    (arguments
+     '(#:tests? #f)) ; needs simplecov, among others
+    (synopsis "Gherkin parser for Ruby")
+    (description "Gherkin 3 is a parser and compiler for the Gherkin language.
+It is intended to replace Gherkin 2 and be used by all Cucumber
+implementations to parse '.feature' files.")
+    (home-page "https://github.com/cucumber/gherkin3")
+    (license license:expat)))