summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-03-13 21:14:39 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-03-13 21:14:39 +0100
commit6c7017269228c1766c62aa425d35f27870c5724c (patch)
tree90449e2be71c27d4233a9a5ec0fd076e5e7d9231
parent80b58d15bc659d5d0b4565b9fa700eabfc38fd83 (diff)
downloadguix-6c7017269228c1766c62aa425d35f27870c5724c.tar.gz
gnu: Add python-quex.
* gnu/packages/python.scm (python-quex): New variable.
-rw-r--r--gnu/packages/python.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2272f15b54..8db00dbf37 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13034,3 +13034,16 @@ filesystem events on Linux.")
     (synopsis "Lexical analyzer generator in Python")
     (description "@code{quex} is a lexical analyzer generator in Python.")
     (license license:lgpl2.1+)))        ; Non-military
+
+(define-public python2-quex
+  (package (inherit python2-quex-0.67.3)
+    (name "python2-quex")
+    (version "0.68.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/quex/DOWNLOAD/quex-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0svc9nla3b9145d6b7fb9dizx412l3difzqw0ilh9lz52nsixw8j"))
+       (file-name (string-append name "-" version ".tar.gz"))))))