summary refs log tree commit diff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 18:54:45 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:07 +0300
commit707ff55502b3710a87ddce367aa1fa2d14b46089 (patch)
treee966ae6439ee374b546f2550fc0d50820924f720
parentf445c75d51ace6fea9c2d85a9dc111b6668eb47f (diff)
downloadguix-707ff55502b3710a87ddce367aa1fa2d14b46089.tar.gz
gnu: Add emacs-helm-gtags.
* gnu/packages/emacs.scm (emacs-helm-gtags): New public variable.
-rw-r--r--gnu/packages/emacs.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 74d07d58b4..c818e69bb1 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8277,3 +8277,23 @@ arXiv, Google Scholar, Library of Congress, etc.
       (description "@code{ewmctrl} provides an Emacs interface to
 @code{wmctrl} command-line window-management program.")
       (license license:gpl3+))))
+
+(define-public emacs-helm-gtags
+  (package
+    (name "emacs-helm-gtags")
+    (version "1.5.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/syohex/emacs-helm-gtags/archive/"
+                    version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1a10snhg6nnnan6w9a7mcziy26vxbsr3c35i0gcarnkdp2yqng36"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/syohex/emacs-helm-gtags")
+    (synopsis "Emacs Helm interface to GNU Global")
+    (description
+     "@code{emacs-helm-gtags} provides a Emacs Helm interface to GNU Global.")
+    (license license:gpl3+)))