summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-18 19:18:38 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-19 06:00:25 +0100
commit780fa70cd333621e4485df3eda3d92ee9af486ac (patch)
tree39f44f5835b36a9e54d11faee98d18e451c45467
parent9c22b13136c52c2cd5ef4088a05d9c2a5ef28465 (diff)
downloadguix-780fa70cd333621e4485df3eda3d92ee9af486ac.tar.gz
gnu: perl-params-validationcompiler: Update to 0.27.
* gnu/packages/perl.scm (perl-params-validationcompiler): Update to 0.27.
[native-inputs]: Add perl-type-tiny for another test.
-rw-r--r--gnu/packages/perl.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index ac9d229f31..403c11045c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6269,7 +6269,7 @@ function call parameters to an arbitrary level of specificity.")
 (define-public perl-params-validationcompiler
   (package
     (name "perl-params-validationcompiler")
-    (version "0.24")
+    (version "0.27")
     (source
       (origin
         (method url-fetch)
@@ -6277,12 +6277,14 @@ function call parameters to an arbitrary level of specificity.")
                             "Params-ValidationCompiler-" version ".tar.gz"))
         (sha256
          (base32
-          "11s29wd7gci4c7gcksxw7pzxfzganvr8x4f1dsww4676p93kg5m8"))))
+          "1cpr188c2xm0kkmdir6slcsgv7v6ibqff4lax8s0whwx6ml9kaah"))))
     (build-system perl-build-system)
     (native-inputs
+     ;; For tests.
      `(("perl-test-without-module" ,perl-test-without-module)
        ("perl-test2-bundle-extended" ,perl-test2-bundle-extended)
-       ("perl-test2-plugin-nowarnings" ,perl-test2-plugin-nowarnings)))
+       ("perl-test2-plugin-nowarnings" ,perl-test2-plugin-nowarnings)
+       ("perl-type-tiny" ,perl-type-tiny)))
     (propagated-inputs
      `(("perl-eval-closure" ,perl-eval-closure)
        ("perl-exception-class" ,perl-exception-class)