summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-04-01 17:56:57 -0400
committerMark H Weaver <mhw@netris.org>2014-04-02 11:27:52 -0400
commit988cecfd4ff1f1d8e7960ed3f52f51af824a681b (patch)
treea2fee42cf1b53f0f5d666511db4faa77a7df9a7a
parent757577896968057cf175e912296ae74015e2d957 (diff)
downloadguix-988cecfd4ff1f1d8e7960ed3f52f51af824a681b.tar.gz
gnu: expect: Install man pages in share/man.
* gnu/packages/tcl.scm (expect): Add --mandir configure flag.
  Use 'let' to simplify configure flags generation.
-rw-r--r--gnu/packages/tcl.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 18324ec94c..3ebdcbe5e2 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -95,14 +95,12 @@
        ("tcl" ,tcl)))
     (arguments
      '(#:configure-flags
-       (list (string-append "--with-tcl="
-                            (assoc-ref %build-inputs "tcl")
-                            "/lib")
-             (string-append "--with-tclinclude="
-                            (assoc-ref %build-inputs "tcl")
-                            "/include")
-             (string-append "--exec-prefix="
-                            (assoc-ref %outputs "out")))
+       (let ((out (assoc-ref %outputs "out"))
+             (tcl (assoc-ref %build-inputs "tcl")))
+         (list (string-append "--with-tcl=" tcl "/lib")
+               (string-append "--with-tclinclude=" tcl "/include")
+               (string-append "--exec-prefix=" out)
+               (string-append "--mandir=" out "/share/man")))
 
        #:phases (alist-cons-before
                  'configure 'set-path-to-stty