summary refs log tree commit diff
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@gnu.org>2018-04-07 12:47:20 +0200
committerTomáš Čech <sleep_walker@gnu.org>2018-04-10 11:43:12 +0200
commita69e0cf3ca84079a6e1765040e9dee5e2858bf9f (patch)
tree6afe5e3939ed129d9aa3f2c09a10ad891d925929
parent60e1de6d95bd32b4996c199708541781b8f828fd (diff)
downloadguix-a69e0cf3ca84079a6e1765040e9dee5e2858bf9f.tar.gz
gnu: Add libcgroup.
 * gnu/packages/linux.scm (libcgroup): New variable.
-rw-r--r--gnu/packages/linux.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index de8dc572de..e774dbb3a0 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4564,3 +4564,30 @@ text-mode or graphical applications that don't use a display server.
 Also included is @command{fbgrab}, a wrapper around @command{fbcat} that
 emulates the behaviour of Gunnar Monell's older fbgrab utility.")
     (license license:gpl2)))
+
+(define-public libcgroup
+  (package
+    (name "libcgroup")
+    (version "0.41")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://sourceforge/libcg/" name "/"
+             version "/" name "-" version ".tar.bz2"))
+       (sha256
+        (base32 "0lgvyq37gq84sk30sg18admxaj0j0p5dq3bl6g74a1ppgvf8pqz4"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f))
+    (native-inputs
+     `(("bison" ,bison)
+       ("flex" ,flex)))
+    (inputs
+     `(("linux-pam" ,linux-pam)))
+    (home-page "https://sourceforge.net/projects/libcg/")
+    (synopsis "Control groups management tools")
+    (description "Control groups is Linux kernel method for process resource
+restriction, permission handling and more.  This package provides userspace
+interface to this kernel feature.")
+    (license license:lgpl2.1)))