summary refs log tree commit diff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:08:21 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:15 +0300
commita79cf99c8b14d11ec23617f7e076e5ccae1d06cd (patch)
treec325628d1b21a6cca2b715cc02d0bb7375be7bf9
parent75a87807eea687caa9f382b36a1386913bf7ae70 (diff)
downloadguix-a79cf99c8b14d11ec23617f7e076e5ccae1d06cd.tar.gz
gnu: Add emacs-highlight-numbers.
* gnu/packages/emacs.scm (emacs-highlight-numbers): New public variable.
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 78b04534ad..d2bccdc53a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9612,3 +9612,29 @@ one place.  It's fast, because you're not leaving the current buffer, and all
 you do is enter the code you'd enter anyway, just placing ~ where you'd like
 yasnippet fields and mirrors to be.")
       (license license:gpl3+))))
+
+(define-public emacs-highlight-numbers
+  (package
+    (name "emacs-highlight-numbers")
+    (version "0.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/Fanael/highlight-numbers/archive/"
+             version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "030v5p11d4n0581ncv499l1fqrmfziy756q6378x2bv22ixghqqp"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-parent-mode" ,emacs-parent-mode)))
+    (home-page "https://github.com/Fanael/highlight-numbers")
+    (synopsis "Highlight numbers in source code")
+    (description "@code{highlight-numbers-mode} provides a minor mode for
+syntax highlighting of numeric literals in source code.
+
+It s customizable: it's easy to add or redefine what exactly consitutes a
+\"number\" in given major mode.  See @code{highlight-numbers-modelist}.")
+    (license license:gpl3+)))