summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-10-30 11:06:25 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-10-30 11:15:09 +0200
commitb1435fe735171c340bc8309209edd2a37c6e5aae (patch)
tree466e333f429c10dec2314e20d5480f981b8399c6
parentf8ddf719f3b4005b0cff0d36a82d23c07f2c2913 (diff)
downloadguix-b1435fe735171c340bc8309209edd2a37c6e5aae.tar.gz
gnu: mupdf: Update to 1.14.
* gnu/packages/pdf.scm (mupdf): Update to 1.14.
[source]: Don't remove all the bundled libraries.
[arguments]: Add 'configure-flags to use system libraries.
-rw-r--r--gnu/packages/pdf.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index e71f814b8d..0dc8ef1205 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -596,7 +596,7 @@ extracting content or merging files.")
 (define-public mupdf
   (package
     (name "mupdf")
-    (version "1.13.0")
+    (version "1.14.0")
     (source
       (origin
         (method url-fetch)
@@ -604,9 +604,17 @@ extracting content or merging files.")
                             name "-" version "-source.tar.xz"))
         (sha256
          (base32
-          "0129k92bav692l6lyw10ryldx7h2f9khjpgnp3f3n4fdsph9hrkl"))
+          "1psnz02w5p7wc1s1ma7vvjmkjfy641xvsh9ykaqzkk84dflnjgk0"))
         (modules '((guix build utils)))
-        (snippet '(begin (delete-file-recursively "thirdparty") #t))))
+        (snippet
+         ;; We keep lcms2 since it is different than our lcms.
+         '(begin
+            (for-each
+              (lambda (dir)
+                (delete-file-recursively (string-append "thirdparty/" dir)))
+              '("curl" "freeglut" "freetype" "harfbuzz" "jbig2dec"
+                "libjpeg" "mujs" "openjpeg" "zlib"))
+                #t))))
     (build-system gnu-build-system)
     (inputs
       `(("curl" ,curl)
@@ -627,6 +635,8 @@ extracting content or merging files.")
       '(#:tests? #f ; no check target
         #:make-flags (list "CC=gcc"
                            "XCFLAGS=-fpic"
+                           "USE_SYSTEM_LIBS=yes"
+                           "USE_SYSTEM_MUJS=yes"
                            (string-append "prefix=" (assoc-ref %outputs "out")))
         #:phases (modify-phases %standard-phases
                   (delete 'configure))))