summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:10:20 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:41:55 +0200
commitef59cf9d3bf64086fda1b0fe205210e9a36d60a0 (patch)
treeb86a24a1fbcfbb5966137e3cc48a4679956df345
parente3c7ac732f81dee2e35a6c8b69423d9d20d7af81 (diff)
downloadguix-ef59cf9d3bf64086fda1b0fe205210e9a36d60a0.tar.gz
gnu: ocaml-ppx-tools: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml-ppx-tools)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Fix indentation.
-rw-r--r--gnu/packages/ocaml.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 338dbb8db4..0d5ec46da4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1948,18 +1948,19 @@ simple (yet expressive) query language to select the tests to run.")
     (name "ocaml-ppx-tools")
     (version "5.1+4.06.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (string-append "https://github.com/alainfrisch/ppx_tools/archive/"
-                            version ".tar.gz"))
-        (sha256 (base32
-                  "0mncpy9v2mcjgnj7s2vqpp2b1ixv54djicfx66ic9wny9d202gj1"))))
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/alainfrisch/ppx_tools.git")
+             (commit version)))
+       (sha256 (base32
+                "1ww4cspdpgjjsgiv71s0im5yjkr3544x96wsq1vpdacq7dr7zwiw"))))
     (build-system ocaml-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases (delete 'configure))
        #:tests? #f))
     (properties
-      `((ocaml4.02-variant . ,(delay ocaml4.02-ppx-tools))))
+     `((ocaml4.02-variant . ,(delay ocaml4.02-ppx-tools))))
     (home-page "https://github.com/alainfrisch/ppx_tools")
     (synopsis "Tools for authors of ppx rewriters and other syntactic tools")
     (description "Tools for authors of ppx rewriters and other syntactic tools.")