summary refs log tree commit diff
diff options
context:
space:
mode:
authorTheodoros Foradis <theodoros@foradis.org>2018-07-08 20:39:24 +0300
committerLudovic Courtès <ludo@gnu.org>2018-07-13 17:28:40 +0200
commitf6c8771463de215dedae268a45d2faa64f222a59 (patch)
tree381098cb946e52eda469e34e49278dacad31307c
parentbca302c67af6969584e60bd1604ea196ecc48c4b (diff)
downloadguix-f6c8771463de215dedae268a45d2faa64f222a59.tar.gz
gnu: Add cppzmq.
* gnu/packages/networking.scm (cppzmq): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/networking.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b72a4734d7..ebf0e86f12 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -22,6 +22,7 @@
 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
 ;;; Copyright © 2018 Tonton <tonton@riseup.net>
 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2018 Theodoros Foradis <theodoros@foradis.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -315,6 +316,35 @@ more.")
 between different versions of ØMQ.")
     (license license:mpl2.0)))
 
+(define-public cppzmq
+  (let ((revision "0")
+        (commit "d9f0f016c07046742738c65e1eb84722ae32d7d4"))
+    (package
+      (name "cppzmq")
+      (version (string-append "4.2.2-" revision "."
+                              (string-take commit 7)))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/zeromq/cppzmq")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "1gmqlm00y6xpa5m6d4ajq3ww63n2w7h4sy997wj81vcqmqx45b1f"))
+                (file-name (string-append name "-" version "-checkout"))))
+      (build-system cmake-build-system)
+      (arguments '(#:tests? #f)) ; No tests.
+      (native-inputs
+       `(("pkg-config" ,pkg-config)))
+      (inputs
+       `(("zeromq" ,zeromq)))
+      (home-page "http://zeromq.org")
+      (synopsis "C++ bindings for the ØMQ messaging library")
+      (description
+       "This package provides header-only C++ bindings for ØMQ.  The header
+files contain direct mappings of the abstractions provided by the ØMQ C API.")
+      (license license:expat))))
+
 (define-public librdkafka
   (package
     (name "librdkafka")