summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-03 22:40:43 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:16 +0200
commit11afd13d70389abeadb274639ddfe1166c8ff4b6 (patch)
tree2abf08f081992742b5aad8fe2728cbfb1f0d0b86
parentf9a97fb553fc26f2ea443f7e425b39fea51e47cd (diff)
downloadguix-11afd13d70389abeadb274639ddfe1166c8ff4b6.tar.gz
gnu: ghc-fgl-arbitrary: Replace "--allow-newer" flags.
* gnu/packages/haskell.scm (ghc-fgl-arbitrary)[arguments]: Replace
"--allow-newer" configure flags with a phase that patches the Cabal file.
-rw-r--r--gnu/packages/haskell.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 75ba7f7993..76e2d22001 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7316,8 +7316,15 @@ supported.  A module of colour names (\"Data.Colour.Names\") is provided.")
          "0ln1szgfy8fa78l3issq4fx3aqnnd54w3cb4wssrfi48vd5rkfjm"))))
     (build-system haskell-build-system)
     (arguments
-     `(#:configure-flags (list "--allow-newer=QuickCheck"
-                               "--allow-newer=hspec")))
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'update-constraints
+           (lambda _
+             (substitute* "fgl-arbitrary.cabal"
+               (("QuickCheck >= 2\\.3 && < 2\\.10")
+                "QuickCheck >= 2.3 && < 2.12")
+               (("hspec >= 2\\.1 && < 2\\.5")
+                "hspec >= 2.1 && < 2.6")))))))
     (inputs
      `(("ghc-fgl" ,ghc-fgl)
        ("ghc-quickcheck" ,ghc-quickcheck)