summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-09 16:51:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-10 17:59:23 +0200
commit1e555562a757c48feae5f0004447f4dc64987807 (patch)
tree68af4a40e241e207b42c2acb05b30f63b2ebf97a
parent9fb20d01c536f4a1b728f5ec8b63715f73bea249 (diff)
downloadguix-1e555562a757c48feae5f0004447f4dc64987807.tar.gz
gnu: Add java-plexus-interpolation.
* gnu/packages/java.scm (java-plexus-interplation): New variable.

Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/java.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 49b953d267..fb01480586 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1232,3 +1232,33 @@ cli/shell/BourneShell.java"
 Plexus framework to ease working with strings, files, command lines, XML and
 more.")
     (license license:asl2.0)))
+
+(define-public java-plexus-interpolation
+  (package
+    (name "java-plexus-interpolation")
+    (version "1.23")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/codehaus-plexus/"
+                                  "plexus-interpolation/archive/"
+                                  "plexus-interpolation-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1w79ljwk42ymrgy8kqxq4l82pgdj6287gabpfnpkyzbrnclsnfrp"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:jar-name "plexus-interpolation.jar"
+       #:source-dir "src/main"))
+    (native-inputs
+     `(("java-junit" ,java-junit)
+       ("java-hamcrest-core" ,java-hamcrest-core)))
+    (home-page "http://codehaus-plexus.github.io/plexus-interpolation/")
+    (synopsis "Java components for interpolating ${} strings and the like")
+    (description "Plexus interpolator is a modular, flexible interpolation
+framework for the expression language style commonly seen in Maven, Plexus,
+and other related projects.
+
+It has its foundation in the @code{org.codehaus.plexus.utils.interpolation}
+package within @code{plexus-utils}, but has been separated in order to allow
+these two libraries to vary independently of one another.")
+    (license license:asl2.0)))