summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-29 00:00:43 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:16 +0200
commitf9a97fb553fc26f2ea443f7e425b39fea51e47cd (patch)
tree714c8abdf2db3ea49fcc6eb9991cb3aec60e23fa
parent96d214a6d9d0585589432de4e2a77523c4590743 (diff)
downloadguix-f9a97fb553fc26f2ea443f7e425b39fea51e47cd.tar.gz
gnu: ghc-doctest: Update to 0.16.0.
* gnu/packages/haskell.scm (ghc-doctest): Update to 0.16.0.
[inputs]: Add ghc-code-page.
-rw-r--r--gnu/packages/haskell.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7b187899ac..75ba7f7993 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5115,7 +5115,7 @@ monad transformer (instead of the IO monad).")
 (define-public ghc-doctest
   (package
     (name "ghc-doctest")
-    (version "0.11.0")
+    (version "0.16.0")
     (source
      (origin
        (method url-fetch)
@@ -5125,13 +5125,14 @@ monad transformer (instead of the IO monad).")
              ".tar.gz"))
        (sha256
         (base32
-         "0xv4vx1r3mk7cmiwywzrq25545cx3i7imhcx33mk47r88j5c49fj"))))
+         "0hkccch65s3kp0b36h7bqhilnpi4bx8kngncm7ma9vbd3dwacjdv"))))
     (build-system haskell-build-system)
     (arguments `(#:tests? #f))          ; FIXME: missing test framework
     (inputs
      `(("ghc-syb" ,ghc-syb)
        ("ghc-paths" ,ghc-paths)
        ("ghc-base-compat" ,ghc-base-compat)
+       ("ghc-code-page" ,ghc-code-page)
        ("ghc-hunit" ,ghc-hunit)
        ("ghc-hspec" ,ghc-hspec)
        ("ghc-quickcheck" ,ghc-quickcheck)