summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-08-29 22:53:34 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-09-06 09:08:47 -0400
commit30b0b725ff358e7d8e645d005f02a0a6e06cfbe9 (patch)
tree36fa6eb4117bb77b9fba8be231d02d00aef150ec
parent386b0052f5ec05ef8bef8662ffa48c98cd80090a (diff)
downloadguix-30b0b725ff358e7d8e645d005f02a0a6e06cfbe9.tar.gz
gnu: Add ruby-method-source.
* gnu/packages/ruby.scm (ruby-method-source): New variable.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5fea0566d9..35b63cf6ac 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -844,3 +844,25 @@ to reproduce user environments.")
 both CSS3 selector and XPath 1.0 support.")
     (home-page "http://www.nokogiri.org/")
     (license license:expat)))
+
+(define-public ruby-method-source
+  (package
+    (name "ruby-method-source")
+    (version "0.8.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "method_source" version))
+       (sha256
+        (base32
+         "1g5i4w0dmlhzd18dijlqw5gk27bv6dj2kziqzrzb7mpgxgsd1sf2"))))
+    (build-system ruby-build-system)
+    (native-inputs
+     `(("ruby-bacon" ,ruby-bacon)
+       ("git" ,git)))
+    (synopsis "Retrieve the source code for Ruby methods")
+    (description "Method_source retrieves the source code for Ruby methods.
+Additionally, it can extract source code from Proc and Lambda objects or just
+extract comments.")
+    (home-page "https://github.com/banister/method_source")
+    (license license:expat)))