summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-11-04 12:37:55 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-11-04 12:37:55 +0100
commit865e66daf3d672bb0acb8a4205f842667124faaf (patch)
tree94ad09625cd4918a3c2762fccfe4bb600ac80b9c
parentef189ab3b82a29991d9952b6c98b2f8c7acc7c88 (diff)
downloadguix-865e66daf3d672bb0acb8a4205f842667124faaf.tar.gz
gnu: Add emacs-windower.
* gnu/packages/emacs-xyz.scm (emacs-windower): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 16d4d8f7ae..7704a555ed 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19772,3 +19772,32 @@ commands that bear resemblance to the input command.")
      "The functions in this package provide the inverse of Emacs'
 @code{fill-paragraph} and @code{fill-region}.")
     (license license:gpl3+)))
+
+(define-public emacs-windower
+  (package
+    (name "emacs-windower")
+    (version "0.0.1")
+    (home-page "https://gitlab.com/ambrevar/emacs-windower")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0h24gb1ip0czfasxm8wwcc3v19g7mznzw2sxkmmfb5iis59p7dfy"))))
+    (build-system emacs-build-system)
+    (synopsis "Helper functions for window manipulation in Emacs")
+    (description
+     "This package provides helper functions for window manipulation in Emacs,
+such as:
+
+@itemize
+- switch to last buffer,
+- toggle single window display,
+- toggle between horizontal and vertical splits,
+- move borders more naturally,
+- swap windows à-la @code{windmove}.
+@end itemize\n")
+    (license license:gpl3+)))