summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-05 21:45:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-05 21:45:55 +0100
commit8e04b233f130e01b5b6a41dfcdeb5e622d43f751 (patch)
tree77fffd3b3c364fba96c7917bd81046e9ac4e8cd2
parent241409cd8afe45fdecfbd7d24cdeb08aa2a43884 (diff)
downloadguix-8e04b233f130e01b5b6a41dfcdeb5e622d43f751.tar.gz
gnu: Add python-asciitree.
* gnu/packages/python-xyz.scm (python-asciitree): New variable.
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0642d32631..c9865d08e2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15759,6 +15759,23 @@ tool).")
 codecs for use in data storage and communication applications.")
     (license license:expat)))
 
+(define-public python-asciitree
+  (package
+    (name "python-asciitree")
+    (version "0.3.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "asciitree" version))
+       (sha256
+        (base32
+         "0vhgri2m2xlnibhz4xwn4hpbc7xacisxjqrk6k5kyppq96vbk92a"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/mbr/asciitree")
+    (synopsis "Draws ASCII trees")
+    (description "This package draws tree structures using characters.")
+    (license license:expat)))
+
 (define-public python-anndata
   (package
     (name "python-anndata")