summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-04-06 12:08:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-04-06 14:39:10 +0200
commitbf6dcf59ebe64a679e141559d979655d24cba7cd (patch)
tree45ddeb1ee893b59becd1fe9e4ea1d4a1ebfd2042
parent1cbb07a8e4c4ee1debc023ee5ce345490699df43 (diff)
downloadguix-bf6dcf59ebe64a679e141559d979655d24cba7cd.tar.gz
gnu: Add r-commonmark.
* gnu/packages/statistics.scm (r-commonmark): New variable.
-rw-r--r--gnu/packages/statistics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 292cc5032e..9bb6a76be2 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2136,6 +2136,30 @@ DESCRIPTION files.  It is intended for packages that create or manipulate
 other packages.")
     (license license:expat)))
 
+(define-public r-commonmark
+  (package
+    (name "r-commonmark")
+    (version "1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "commonmark" version))
+       (sha256
+        (base32
+         "12q5mncxvkwdxc35is6y5idx8a1h99hyz5x6ri0arni6k25krchk"))))
+    (build-system r-build-system)
+    ;;(inputs `(("zlib" ,zlib)))
+    (home-page "http://cran.r-project.org/web/packages/commonmark")
+    (synopsis "CommonMark and Github Markdown Rendering in R")
+    (description
+     "The CommonMark specification defines a rationalized version of markdown
+syntax.  This package uses the 'cmark' reference implementation for converting
+markdown text into various formats including HTML, LaTeX and groff man.  In
+addition, it exposes the markdown parse tree in XML format.  The latest
+version of this package also adds support for Github extensions including
+tables, autolinks and strikethrough text.")
+    (license license:bsd-2)))
+
 (define-public r-roxygen2
   (package
     (name "r-roxygen2")