summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-18 14:03:08 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-01-07 17:18:16 +0100
commitcefaa79c9eb13ef7c84a038b09f147a19aea3aba (patch)
treea54e684339725d40c11f12fa2f799496896bbc7a
parent21e4d6a9cfdd78f307a6951b0911207e386e2097 (diff)
downloadguix-cefaa79c9eb13ef7c84a038b09f147a19aea3aba.tar.gz
gnu: Add RCurl.
* gnu/packages/statistics.scm (r-rcurl): New variable.
-rw-r--r--gnu/packages/statistics.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index d41973321e..0dd3a4f0ed 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -27,6 +27,7 @@
   #:use-module (guix build-system python)
   #:use-module (gnu packages)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages haskell)
@@ -1519,3 +1520,34 @@ interface compliant with the DBI package.  The source for the SQLite
 engine (version 3.8.6) is included.")
     (license license:lgpl2.0+)))
 
+(define-public r-rcurl
+  (package
+    (name "r-rcurl")
+    (version "1.95-0.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.bioconductor.org/packages/"
+                                  "release/extra/src/"
+                                  "contrib/RCurl_" version ".tar.gz"))
+              (sha256
+               (base32
+                "0l7qi45jxlf898n0jazabnam1yyczvqfdknd00bdirhhiplpd1sc"))))
+    (properties `((upstream-name . "RCurl")))
+    (build-system r-build-system)
+    (inputs
+     `(("libcurl" ,curl)))
+    (propagated-inputs
+     `(("r-bitops" ,r-bitops)))
+    (home-page "http://www.omegahat.org/RCurl")
+    (synopsis "General network client interface for R")
+    (description
+     "The package allows one to compose general HTTP requests and provides
+convenient functions to fetch URIs, GET and POST forms, etc. and process the
+results returned by the Web server.  This provides a great deal of control
+over the HTTP/FTP/... connection and the form of the request while providing a
+higher-level interface than is available just using R socket connections.
+Additionally, the underlying implementation is robust and extensive,
+supporting FTP/FTPS/TFTP (uploads and downloads), SSL/HTTPS, telnet, dict,
+ldap, and also supports cookies, redirects, authentication, etc.")
+    (license license:bsd-3)))
+