summary refs log tree commit diff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-03-30 16:02:08 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-04-02 10:14:17 +1000
commitcf1d581464645b3f96ead827010f84ef7d714506 (patch)
treeca236376093078d5145d13f68084797383636f06
parent4fbed7494d782f1a1ee027e1a3a2d2e4b12a53ab (diff)
downloadguix-cf1d581464645b3f96ead827010f84ef7d714506.tar.gz
gnu: khmer: Build with gcc-4.
* gnu/packages/bioinformatics.scm (khmer)[inputs]: Add gcc-4.9.
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3c0366814b..7c21586fcf 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3150,7 +3150,10 @@ command, or queried for specific k-mers with @code{jellyfish query}.")
      `(("zlib" ,zlib)
        ("bzip2" ,bzip2)
        ("python-screed" ,python-screed)
-       ("python-bz2file" ,python-bz2file)))
+       ("python-bz2file" ,python-bz2file)
+       ;; Tests fail when gcc-5 is used for compilation.  Use gcc-4.9 at least
+       ;; until the next version of khmer (likely 2.1) is released.
+       ("gcc" ,gcc-4.9)))
     (home-page "https://khmer.readthedocs.org/")
     (synopsis "K-mer counting, filtering and graph traversal library")
     (description "The khmer software is a set of command-line tools for