summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2016-04-03 21:36:29 +0200
committerLeo Famulari <leo@famulari.name>2016-04-11 19:46:21 -0400
commit5f3f3ac287467994f01646680c6a6837ec7ee587 (patch)
treeffccda9067d6034703e1454cdb6df061d5a19049
parentdf887432be25e1534b9ecdccf39c98857b1d0786 (diff)
downloadguix-5f3f3ac287467994f01646680c6a6837ec7ee587.tar.gz
gnu: btrfs-progs: Add "static" output.
* gnu/packages/linux.scm (btrfs-progs)[outputs]: New field.
[inputs]: Add "static" outputs of util-linux for libuuid and libblkid.
[arguments]: Add 'build-static' and 'install-static' phases.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/linux.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6c669e3160..2920298b36 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2509,12 +2509,26 @@ and copy/paste text in the console and in xterm.")
                (base32
                 "1znf2zhb56zbmdjk3lq107678xwsqwc5gczspypmc5i31qnppy7f"))))
     (build-system gnu-build-system)
+    (outputs '("out"
+               "static"))      ; static versions of binaries in "out" (~16MiB!)
     (arguments
-     '(#:test-target "test"
+     '(#:phases (modify-phases %standard-phases
+                 (add-after 'build 'build-static
+                   (lambda _ (zero? (system* "make" "static"))))
+                 (add-after 'install 'install-static
+                   (let ((staticbin (string-append (assoc-ref %outputs "static")
+                                                  "/bin")))
+                     (lambda _
+                       (zero? (system* "make"
+                                       (string-append "bindir=" staticbin)
+                                       "install-static"))))))
+       #:test-target "test"
        #:parallel-tests? #f)) ; tests fail when run in parallel
     (inputs `(("e2fsprogs" ,e2fsprogs)
               ("libblkid" ,util-linux)
+              ("libblkid:static" ,util-linux "static")
               ("libuuid" ,util-linux)
+              ("libuuid:static" ,util-linux "static")
               ("zlib" ,zlib)
               ("lzo" ,lzo)))
     (native-inputs `(("pkg-config" ,pkg-config)