summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-06 14:08:08 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:10 +0200
commite09ef4fccaddfeb74ecab8cc7ab9a24be9b019f9 (patch)
tree5b339485d28b53382fd1f880a6d97a707781cfee
parent6c76f51f96737d5e0fc2148343b4f5605a6e95a4 (diff)
downloadguix-e09ef4fccaddfeb74ecab8cc7ab9a24be9b019f9.tar.gz
gnu: ghc-zlib: Relax test framework dependency constraints.
* gnu/packages/haskell.scm (ghc-zlib)[arguments]: Remove "--allow-newer"
configure flag and add a phase that removes dependency version constraints
from some of the test frameworks.
-rw-r--r--gnu/packages/haskell.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 696f42118d..9ed7554bb0 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2044,7 +2044,15 @@ literals.")
         (base32
          "1vbzf0awb6zb456xf48za1kl22018646cfzq4frvxgb9ay97vk0d"))))
     (build-system haskell-build-system)
-    (arguments `(#:configure-flags (list "--allow-newer=tasty")))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'strip-test-framework-constraints
+           (lambda _
+             (substitute* "zlib.cabal"
+               (("tasty            >= 0\\.8 && < 0\\.12") "tasty")
+               (("tasty-hunit      >= 0\\.8 && < 0\\.10") "tasty-hunit")
+               (("tasty-quickcheck == 0\\.8\\.\\*") "tasty-quickcheck")))))))
     (inputs `(("zlib" ,zlib)))
     (native-inputs
      `(("ghc-quickcheck" ,ghc-quickcheck)