summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 14:11:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:49 +0100
commit029425cbcefe427bd4816110780acc5566ea9785 (patch)
tree828b36c25c52d04000566de4863b047a28b06e0b
parent5574cb812aec70dca7c99498487c3ef28318a828 (diff)
downloadguix-029425cbcefe427bd4816110780acc5566ea9785.tar.gz
gnu: Add r-vbsr.
* gnu/packages/cran.scm (r-vbsr): New variable.
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 87fd7d341a..1839ead07c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8927,3 +8927,25 @@ few eigenvalues/vectors of an n by n matrix, e.g., the k largest eigenvalues,
 which is usually more efficient than @code{eigen()} if k << n.")
     ;; MPL 2 or later.
     (license license:mpl2.0)))
+
+(define-public r-vbsr
+  (package
+    (name "r-vbsr")
+    (version "0.0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "vbsr" version))
+       (sha256
+        (base32
+         "1avskbxxyinjjdga4rnghcfvd4sypv4m39ysfaij5avvmi89bx3b"))))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/web/packages/vbsr")
+    (synopsis "Variational Bayes spike regression regularized linear models")
+    (description
+     "This package provides an efficient algorithm for solving ultra-sparse
+regularized regression models using a variational Bayes algorithm with a spike
+prior.  The algorithm is solved on a path, with coordinate updates, and is
+capable of generating very sparse models.  Very general model
+diagnostics for controlling type-1 errors are also provided.")
+    (license license:gpl2)))