summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-30 22:22:30 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:47:48 -0500
commit064a967ba0480d35d706f96e8aa5bb86f0947b4d (patch)
treed6ffb0b137283662a313a7bdcd39c5ee0795baaa
parent477246878b766edb30a780190b2cead0c4b29156 (diff)
downloadguix-064a967ba0480d35d706f96e8aa5bb86f0947b4d.tar.gz
gnu: Use GHC 8.6.5 as the main Haskell compiler.
* gnu/package/haskell.scm (ghc-8): Change to 'ghc-8.6'.
* guix/import/hackage.scm (ghc-standard-libraries): Add 'ghc-heap'
and 'libiserv'.
-rw-r--r--gnu/packages/haskell.scm2
-rw-r--r--guix/import/hackage.scm6
2 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d86daa52c5..8db650e6ae 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -604,7 +604,7 @@ interactive environment for the functional language Haskell.")
                                 (file-pattern ".*\\.conf\\.d$")
                                 (file-type 'directory))))))
 
-(define-public ghc-8 ghc-8.4)
+(define-public ghc-8 ghc-8.6)
 
 (define-public ghc ghc-8)
 
diff --git a/guix/import/hackage.scm b/guix/import/hackage.scm
index 5fe3d85a7f..9cf07c9504 100644
--- a/guix/import/hackage.scm
+++ b/guix/import/hackage.scm
@@ -52,8 +52,8 @@
             hackage-package?))
 
 (define ghc-standard-libraries
-  ;; List of libraries distributed with ghc (8.4.3).
-  ;; Contents of ...-ghc-8.4.3/lib/ghc-8.4.3.
+  ;; List of libraries distributed with ghc (8.6.5).
+  ;; Contents of ...-ghc-8.6.5/lib/ghc-8.6.5.
   '("ghc"
     "cabal" ;; in the output of `ghc-pkg list` Cabal is uppercased, but
             ;; hackage-name->package-name takes this into account.
@@ -70,11 +70,13 @@
     "ghc-boot"
     "ghc-boot-th"
     "ghc-compact"
+    "ghc-heap"
     "ghc-prim"
     "ghci"
     "haskeline"
     "hpc"
     "integer-gmp"
+    "libiserv"
     "mtl"
     "parsec"
     "pretty"