summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-12 15:44:03 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-12 18:39:58 +0200
commit196e35794c8598d28613d702311c365d4d9e0c36 (patch)
tree7a38f20e100ea0330845455009f626c6e86d8aef
parent72e7cba286f07ed6702e3a7a523cbc40e554f4e5 (diff)
downloadguix-196e35794c8598d28613d702311c365d4d9e0c36.tar.gz
gnu: twolame: Update to 0.4.0.
* gnu/packages/audio.scm (twolame): Update to 0.4.0.
[source](snippet): Remove.
-rw-r--r--gnu/packages/audio.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 58547a2cca..88f3b5eccd 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2771,22 +2771,14 @@ conversion.  It may be used, for example, to resample PCM-encoded audio.")
 (define-public twolame
   (package
     (name "twolame")
-    (version "0.3.13")
+    (version "0.4.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://sourceforge/twolame/twolame/" version
                            "/twolame-" version ".tar.gz"))
        (sha256
-        (base32 "0ahiqqng5pidwhj1wzph4vxxgxxgcfa3gl0gywipzx2ii7s35wwq"))
-       (modules '((guix build utils)))
-       ;; The tests break with Perl 5.24:
-       ;; https://github.com/njh/twolame/issues/21
-       ;; TODO: Remove this snippet when upgrading twolame.
-       (snippet
-        '(begin
-           (substitute* "tests/test.pl" (("\\(@_\\)") "($_[0])"))
-           #t))))
+        (base32 "0zf8sxqb02w07ah55b1y7ab643zmpbhn62spa9pqra0rc17l4dfc"))))
     (build-system gnu-build-system)
     (inputs
      `(("libsndfile" ,libsndfile)))