summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-01 04:43:34 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-09-01 04:44:35 +0200
commit1c4b3512db48a34aa5e7993167aa70a3124cdf34 (patch)
tree609ef13d67cb2211a8c5519e93b66cbcea551225
parent7395ea0de42712414402a1b230763799729d4e31 (diff)
downloadguix-1c4b3512db48a34aa5e7993167aa70a3124cdf34.tar.gz
gnu: editorconfig-core-c: Delete static library.
* gnu/packages/text-editors.scm (editorconfig-core-c)[arguments]: Add a
‘delete-static-library’ phase.
-rw-r--r--gnu/packages/text-editors.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index e0f07832f2..5b7f2e937c 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -727,7 +727,14 @@ in plain text file format.")
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((tests (assoc-ref inputs "tests")))
                (copy-recursively tests "tests"))
-             #t)))))
+             #t))
+         (add-after 'install 'delete-static-library
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (lib (string-append out "/lib")))
+               (with-directory-excursion lib
+                 (delete-file "libeditorconfig_static.a"))
+               #t))))))
     (native-inputs
      `(("tests"
         ,(origin