summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:18 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:10:00 -0400
commit23feb6e4fbc42e47d0d36b8f7710366e5cf1e472 (patch)
tree27d2f8556cda8fab922fdad19b273cc65b0f83cd
parent58c85b1f8263a26e36f541e626ac7b30668bf1d2 (diff)
downloadguix-23feb6e4fbc42e47d0d36b8f7710366e5cf1e472.tar.gz
gnu: Add ghc-system-filepath.
* gnu/packages/haskell.scm (ghc-system-filepath): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b497380008..35fcf6d847 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7353,4 +7353,31 @@ testing strategies.")
 easily work with command-line options.")
     (license license:expat)))
 
+(define-public ghc-system-filepath
+  (package
+    (name "ghc-system-filepath")
+    (version "0.4.13.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/system-filepath/system-filepath-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "1yy5zsmmimhg6iaw9fmpwrxvxrgi5s6bfyqfihdsnx4bjvn7sp9l"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-text" ,ghc-text)
+       ("ghc-chell" ,ghc-chell)
+       ("ghc-chell-quickcheck" ,ghc-chell-quickcheck)
+       ("ghc-quickcheck" ,ghc-quickcheck)))
+    (home-page "https://github.com/fpco/haskell-filesystem")
+    (synopsis "High-level, byte-based file and directory path manipulations")
+    (description
+     "Provides a FilePath datatype and utility functions for operating on it.
+Unlike the filepath package, this package does not simply reuse String,
+increasing type safety.")
+    (license license:expat)))
+
 ;;; haskell.scm ends here