summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 14:03:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:49 +0100
commit5574cb812aec70dca7c99498487c3ef28318a828 (patch)
tree4a36a8c3fedd07456ab4dd7b0569de1dcc61b61d
parent3088b3fc5b271c23face4cf82b0938f6aa872462 (diff)
downloadguix-5574cb812aec70dca7c99498487c3ef28318a828.tar.gz
gnu: Add r-rpostgresql.
* gnu/packages/cran.scm (r-rpostgresql): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3e2e9298d6..87fd7d341a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2329,6 +2329,32 @@ is being phased out.  A modern MySQL client based on Rcpp is available from
 the RMariaDB package.")
     (license license:gpl2)))
 
+(define-public r-rpostgresql
+  (package
+    (name "r-rpostgresql")
+    (version "0.6-2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "RPostgreSQL" version))
+       (sha256
+        (base32
+         "1mdhw5821v2h7hpa53v10wz53k4i90r0vb6a3dia5gq8f9j1h088"))))
+    (properties `((upstream-name . "RPostgreSQL")))
+    (build-system r-build-system)
+    (inputs
+     `(("postgresql" ,postgresql)))
+    (propagated-inputs
+     `(("r-dbi" ,r-dbi)))
+    (home-page "https://github.com/tomoakin/RPostgreSQL")
+    (synopsis "R interface to the PostgreSQL database system")
+    (description
+     "This package provides a Database Interface (DBI) compliant driver for R
+to access PostgreSQL database systems.")
+    ;; The whole package is released under GPL version 2.  It includes code
+    ;; under the PostgreSQL license.
+    (license license:gpl2)))
+
 (define-public r-geometry
   (package
     (name "r-geometry")