summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-14 18:30:48 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:29 +0200
commit57388f36ed1b34aab1ec89a74d827928abe36316 (patch)
tree9e92ab1ffbc8754f50eab508035889d7acf032aa
parent31c1c18677422f5d9f7f7ef1f1596830bd628167 (diff)
downloadguix-57388f36ed1b34aab1ec89a74d827928abe36316.tar.gz
gnu: Add rust-scroll-derive-0.9.
* gnu/packages/crates-io.scm (rust-scroll-derive-0.9): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 46e36c00a7..845084c794 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5379,6 +5379,35 @@ with one of the implemented strategies.")
          (base32
           "09sy9wbqp409pkwmqni40qmwa99ldqpl48pp95m1xw8sc19qy9cl"))))))
 
+(define-public rust-scroll-derive-0.9
+  (package
+    (name "rust-scroll-derive")
+    (version "0.9.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "scroll_derive" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1jqg5mm8nvii6avl1z1rc89agzh2kwkppgpsnwfakxg78mnaj6lg"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-proc-macro2" ,rust-proc-macro2-0.4)
+        ("rust-quote" ,rust-quote-1.0)
+        ("rust-syn" ,rust-syn-0.15))
+       #:cargo-development-inputs
+       (("rust-scroll" ,rust-scroll-0.9))))
+    (home-page "https://github.com/m4b/scroll_derive")
+    (synopsis "Derive Pread and Pwrite traits from the scroll crate")
+    (description
+     "This package provides a macros 1.1 derive implementation for Pread and
+Pwrite traits from the scroll crate.")
+    (license license:expat)))
+
 (define-public rust-security-framework-sys-0.3
   (package
     (name "rust-security-framework-sys")