summary refs log tree commit diff
diff options
context:
space:
mode:
authorHolger Peters <holger.peters@posteo.de>2020-05-20 09:07:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-05-20 09:31:26 +0200
commit79ddf25bc0a26a52ffe88c144d6ce2645462fa05 (patch)
tree384ffd4a87b3b57a601fd8d594118a2423bba0de
parentc557ae13f901d0f2e74dd2f29612a03c23704cd6 (diff)
downloadguix-79ddf25bc0a26a52ffe88c144d6ce2645462fa05.tar.gz
gnu: Add python-plaster.
* gnu/packages/python-web.scm (python-plaster): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e7b8b3b198..adc68f48c7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3899,3 +3899,27 @@ displaying warnings when usaged in application code.")
 project packages for internationalization (i18n) duties related to
 translation.")
     (license license:repoze)))
+
+(define-public python-plaster
+  (package
+    (name "python-plaster")
+    (version "1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "plaster" version))
+              (sha256
+               (base32
+                "1hy8k0nv2mxq94y5aysk6hjk9ryb4bsd13g83m60hcyzxz3wflc3"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
+    (home-page "https://docs.pylonsproject.org/projects/plaster/en/latest/")
+    (synopsis "Configuration loader for multiple config file formats")
+    (description
+     "Plaster is a loader interface around multiple config file formats.  It
+exists to define a common API for applications to use when they wish to load
+configuration.  The library itself does not aim to handle anything except a
+basic API that applications may use to find and load configuration settings.
+Any specific constraints should be implemented in a pluggable loader which can
+be registered via an entrypoint.")
+    (license license:repoze)))