summary refs log tree commit diff
diff options
context:
space:
mode:
authorHolger Peters <holger.peters@posteo.de>2020-05-20 09:07:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-05-20 09:33:04 +0200
commit8bfc0512da448007ae7c0688802d4dc8bf27fa61 (patch)
treefc3ad86f1a5302030cc8933852e6d1bb1c1f1cfb
parent804b7722a5272dffe659368404a3447e509f2cea (diff)
downloadguix-8bfc0512da448007ae7c0688802d4dc8bf27fa61.tar.gz
gnu: Add python-hupper.
* gnu/packages/python-web.scm (python-hupper): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ddd94c09cb..604c59c083 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3947,3 +3947,31 @@ be registered via an entrypoint.")
 syntax, it provides a plaster @code{Loader} object that can parse ini files
 according to the standard set by PasteDeploy ")
     (license license:expat)))
+
+(define-public python-hupper
+  (package
+    (name "python-hupper")
+    (version "1.10.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "hupper" version))
+              (sha256
+               (base32
+                "0am0p6g5cz6xmcaf04xq8q6dzdd9qz0phj6gcmpsckf2mcyza61q"))))
+    (build-system python-build-system)
+    (arguments '(#:test-target "pytest"))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-runner" ,python-pytest-runner)
+       ("python-watchdog" ,python-watchdog)
+       ("python-mock" ,python-mock)
+       ("python-pytest-cov" ,python-pytest-cov)))
+    (propagated-inputs
+     `(("python-pytz" ,python-pytz)))
+    (home-page "https://readthedocs.org/projects/hupper")
+    (synopsis "Integrated process monitor tracking changes to imported Python files")
+    (description
+     "Hupper is an integrated process monitor that will track changes to any
+imported Python files in sys.modules as well as custom paths.  When files are
+changed the process is restarted.")
+    (license license:expat)))