summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-12 15:16:06 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-12 15:17:29 -0500
commita4cfdab56a09edf24c6a338a4752e7a70d235b35 (patch)
tree0b3f85c6d8702baaff7c720bdc94a34d72260af7
parent3de898b43c1388a9244bdedd2d9f11511c9571d2 (diff)
downloadguix-a4cfdab56a09edf24c6a338a4752e7a70d235b35.tar.gz
gnu: python-flask-basicauth: Fix build.
* gnu/packages/python-web.scm (python-flask-basicauth)[phases]: Add a
'fix-imports phase.
-rw-r--r--gnu/packages/python-web.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cf71a64e7c..fccb7603ac 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -26,7 +26,7 @@
 ;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
 ;;; Copyright © 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
 ;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
@@ -2895,6 +2895,17 @@ pretty printer and a tree visitor.")
           (base32
             "1zq1spkjr4sjdnalpp8wl242kdqyk6fhbnhr8hi4r4f0km4bspnz"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'fix-imports
+                    (lambda _
+                      (substitute* '("docs/index.rst"
+                                     "docs/conf.py"
+                                     "flask_basicauth.py"
+                                     "test_basicauth.py")
+                        (("flask\\.ext\\.basicauth")
+                         "flask_basicauth"))
+                      #t)))))
     (propagated-inputs
      `(("python-flask" ,python-flask)))
     (home-page