summary refs log tree commit diff
diff options
context:
space:
mode:
authorSam <smbaines8@gmail.com>2019-03-17 18:08:29 +0000
committerLeo Famulari <leo@famulari.name>2019-03-18 12:59:08 -0400
commita91f4eba2c923405ccdce5bdb390b12a40a856c2 (patch)
tree0e1ec4d9f7a5084f11fa9d90ef108d9f43589dc2
parent4cb0b5bfd784a314a97172e93c19b8c4493caf98 (diff)
downloadguix-a91f4eba2c923405ccdce5bdb390b12a40a856c2.tar.gz
gnu: Add python-shortuuid.
* gnu/packages/python-xyz.scm (python-shortuuid): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f9e87fb9c7..f9617b1603 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -58,6 +58,7 @@
 ;;; Copyright © 2018 Luther Thompson <lutheroto@gmail.com>
 ;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
 ;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
+;;; Copyright © 2019 Sam <smbaines8@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -230,6 +231,28 @@ pidof, tty, taskset, pmap.")
 planar geometric objects.  It is based on the @code{GEOS} library.")
     (license license:bsd-3)))
 
+(define-public python-shortuuid
+  (package
+    (name "python-shortuuid")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "shortuuid" version))
+       (sha256
+        (base32
+         "1f8i4zwj5vmpzbz6b17bljy4399gx5aq7vsyw63sz2qgyjcd73yh"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pep8" ,python-pep8)))
+    (home-page "https://github.com/skorokithakis/shortuuid")
+    (synopsis "Generator library for concise, unambiguous and URL-safe UUIDs")
+    (description
+     "@code{shortuuid} is a Python library for generating concise, unambiguous
+and URL-safe UUIDs.  UUIDs are generated using the built-in Python @code{uuid}
+module and then similar looking characters are removed.")
+    (license license:bsd-3)))
+
 (define-public python-logwrap
   (package
     (name "python-logwrap")