summary refs log tree commit diff
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-19 22:16:38 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-27 19:50:41 +0800
commitcbea1e8dd22c01b8c228afc0b74dfe39ed356d37 (patch)
treef8561aaf82ae6d3f735727f32a7f85a0c6f1c738
parent6f00fb75ca52ae112a73f2fbc6d8f6269a8db5f6 (diff)
downloadguix-cbea1e8dd22c01b8c228afc0b74dfe39ed356d37.tar.gz
gnu: lxqt-build-tools: Define LXQT_DATA_DIR and LXQT_ETC_XDG_DIR.
* gnu/packages/lxqt.scm (lxqt-build-tools)[arguments]: Define LXQT_DATA_DIR
and LXQT_ETC_XDG_DIR in the configure flags.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/lxqt.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 1c6bfb7b60..b78b8ac99f 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -131,7 +131,13 @@ to statistics about the system on which it's run.")
         (base32 "13b5x26p6ycnwzlgg1cgvlc88wjrjmlb3snrrmzh0xgh9h6hhvd6"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f))                    ; no tests
+     `(#:tests? #f                      ; no tests
+       #:configure-flags
+       ;; 'startlxqt' will add LXQT_DATA_DIR to XDG_DATA_DIRS,
+       ;; LXQT_ETC_XDG_DIR to XDG_CONFIG_DIRS, and 'lxqt-about' will report
+       ;; LXQT_ETC_XDG_DIR in its "Technical Info".
+       '("-DLXQT_DATA_DIR=/run/current-system/profile/share"
+         "-DLXQT_ETC_XDG_DIR=/run/current-system/profile/etc/xdg")))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("glib" ,glib)))