summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-01-16 19:59:26 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-21 16:23:59 +0200
commitd9b2c855bfaeacbe02321b92705653a2b613551d (patch)
treef02f92fb9ed6787b60d18001b29368263e7cb7e0
parent8f414fa29dc54a40fdfa94a897eda0795f6cb355 (diff)
downloadguix-d9b2c855bfaeacbe02321b92705653a2b613551d.tar.gz
gnu: Add rust-thread-local-1.0.
* gnu/packages/crates-io.scm (rust-thread-local-1.0): New variable.
(rust-thread-local-0.3): Inherit from rust-thread-local-1.0.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 17 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7bbaf60324..e001c8bbbb 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -11413,10 +11413,10 @@ different for every thread.")
     (license (list license:asl2.0
                    license:expat))))
 
-(define-public rust-thread-local-0.3
+(define-public rust-thread-local-1.0
   (package
     (name "rust-thread-local")
-    (version "0.3.6")
+    (version "1.0.1")
     (source
       (origin
         (method url-fetch)
@@ -11424,7 +11424,7 @@ different for every thread.")
         (file-name (string-append name "-" version ".crate"))
         (sha256
          (base32
-          "06rzik99p8c5js8238yhc8rk6np543ylb1dy9nrw5v80j0r3xdf6"))))
+          "054vlrr1vsdy1h4b7n99mr24pnj8928ig9qwzg36wnkld4dns36l"))))
     (build-system cargo-build-system)
     (home-page "https://github.com/Amanieu/thread_local-rs")
     (synopsis "Per-object thread-local storage")
@@ -11433,6 +11433,20 @@ different for every thread.")
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-thread-local-0.3
+  (package
+    (inherit rust-thread-local-1.0)
+    (name "rust-thread-local")
+    (version "0.3.6")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "thread_local" version))
+        (file-name (string-append name "-" version ".crate"))
+        (sha256
+         (base32
+          "06rzik99p8c5js8238yhc8rk6np543ylb1dy9nrw5v80j0r3xdf6"))))))
+
 (define-public rust-threadpool-1.7
   (package
     (name "rust-threadpool")