summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-10 23:37:48 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-10 23:42:54 +0100
commite17f867c62c687779a82d05db73ab63c25d49c4e (patch)
treec81eb929d86fc8e12c45ff4eb965be7b713f6571
parent7db147ec455b11c9717c4ac3730bf1139b370897 (diff)
downloadguix-e17f867c62c687779a82d05db73ab63c25d49c4e.tar.gz
gnu: wmbattery: Remove custom bootstrap phase.
* gnu/packages/gnustep.scm (wmbattery)[arguments]: Remove autoconf phase.
-rw-r--r--gnu/packages/gnustep.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
index bd28ceaa00..3cc5540ae7 100644
--- a/gnu/packages/gnustep.scm
+++ b/gnu/packages/gnustep.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -167,14 +168,7 @@ interface.  It is fast, feature rich, easy to configure, and easy to use.")
                (base32
                 "084a3irxbmgms4bqaga80mlx9wgvlkx6d2w0ns939yrpfzg87laj"))))
     (build-system gnu-build-system)
-    (arguments
-     `(#:tests? #f              ; no "check" target
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'autoconf
-           (lambda _
-             (invoke "autoreconf" "-vfi")
-             #t)))))
+    (arguments '(#:tests? #f)) ; no "check" target
     (inputs
      `(("glib" ,glib)
        ("libx11" ,libx11)