summary refs log tree commit diff
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-10-16 08:36:28 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-10-16 19:53:37 +0200
commitfbea821a2ad15bbe8bf70cd86cff42ae8efc90fa (patch)
treec7d615deefaf0cfc27f253f2b428a942c2d46e55
parent8cff2e7aed888b3d0e4dcfcda151bc8af68fa1bb (diff)
downloadguix-fbea821a2ad15bbe8bf70cd86cff42ae8efc90fa.tar.gz
gnu: bluez: Skip non-deterministic test on all architectures.
* gnu/packages/linux.scm (bluez): [arguments]: Skip unit/test-gatt regardless
of architecture.
-rw-r--r--gnu/packages/linux.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 27ad92e36e..cc0a3cee68 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3071,16 +3071,14 @@ Bluetooth audio output devices like headphones or loudspeakers.")
                (string-append "--with-udevdir=" out "/lib/udev")))
        #:phases
        (modify-phases %standard-phases
-         ,@(if (string=? (%current-system) "armhf-linux")
-               ;; This test fails unpredictably.
-               ;; TODO: skip it for all architectures.
-               `((add-before 'check 'skip-wonky-test
-                  (lambda _
-                    (substitute* "unit/test-gatt.c"
-                      (("tester_init\\(&argc, &argv\\);") "return 77;"))
-                    #t)))
-               `())
-
+         ;; Test unit/test-gatt fails unpredictably. Seems to be a timing
+         ;; issue (discussion on upstream mailing list:
+         ;; https://marc.info/?t=149578476300002&r=1&w=2)
+         (add-before 'check 'skip-wonky-test
+            (lambda _
+              (substitute* "unit/test-gatt.c"
+                (("tester_init\\(&argc, &argv\\);") "return 77;"))
+              #t))
          (add-after 'install 'post-install
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out        (assoc-ref outputs "out"))