summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 13:33:24 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:44 -0500
commit10707d572034e7389211cbe3df30dd92f93124f7 (patch)
tree6fbb56b956b2c9078a0eb6a0f1baa8ade6e85d9d
parent1e0db876d1fb37720f1a9697f9bda34a17ab6e84 (diff)
downloadguix-10707d572034e7389211cbe3df30dd92f93124f7.tar.gz
gnu: ghc-haddock-library: Update to 1.7.0.
The new source tarball does not have bundled dependencies, so it does
not need to be patched.

* gnu/packages/haskell-xyz.scm (ghc-haddock-library): Update to 1.7.0.
[source]: Remove 'patches', 'modules' and 'snippet'.
[arguments]: Update the 'relax-test-suite-dependencies' phase to allow
newer versions of 'hspec' and 'QuickCheck'; remove the
'add-examples-directory' phase.
* gnu/packages/patches/ghc-haddock-library-unbundle.patch: Delete file.
* gnu/local.mk: Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/haskell-xyz.scm23
-rw-r--r--gnu/packages/patches/ghc-haddock-library-unbundle.patch86
3 files changed, 6 insertions, 104 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9c4d1013d8..fd18592582 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -880,7 +880,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/ghc-8.0-fall-back-to-madv_dontneed.patch \
   %D%/packages/patches/ghc-diff-swap-cover-args.patch           \
   %D%/packages/patches/ghc-dont-pass-linker-flags-via-response-files.patch	\
-  %D%/packages/patches/ghc-haddock-library-unbundle.patch	\
   %D%/packages/patches/ghc-hpack-fix-tests.patch		\
   %D%/packages/patches/ghc-monad-par-fix-tests.patch		\
   %D%/packages/patches/ghostscript-no-header-id.patch		\
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 37f56df89b..bd5b599ace 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4328,7 +4328,7 @@ documentation-generation tool for Haskell libraries.")
 (define-public ghc-haddock-library
   (package
     (name "ghc-haddock-library")
-    (version "1.5.0.1")
+    (version "1.7.0")
     (source
      (origin
        (method url-fetch)
@@ -4338,29 +4338,18 @@ documentation-generation tool for Haskell libraries.")
              ".tar.gz"))
        (sha256
         (base32
-         "1cmbg8l5xrwpliclwy3l057raypjqy0hsg1h1743ahaj8gq10b7z"))
-       (patches (search-patches
-                 "ghc-haddock-library-unbundle.patch"))
-       (modules '((guix build utils)))
-       (snippet '(begin
-                   (delete-file-recursively "vendor")
-                   #t))))
+         "04fhcjk0pvsaqvsgp2w06cv2qvshq1xs1bwc157q4lmkgr57khp7"))))
     (build-system haskell-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         ;; Since there is no revised Cabal file upstream, we have to
+         ;; patch it manually.
          (add-before 'configure 'relax-test-suite-dependencies
            (lambda _
              (substitute* "haddock-library.cabal"
-               (("base-compat\\s*\\^>= 0\\.9\\.3") "base-compat")
-               (("hspec\\s*\\^>= 2\\.4\\.4") "hspec"))))
-         ;; The release tarball does not contain the "fixtures/examples"
-         ;; directory, which is required for testing.  In the upstream
-         ;; repository, the directory exists and is populated.  Here, we
-         ;; create an empty directory to placate the tests.
-         (add-before 'check 'add-examples-directory
-           (lambda _
-             (mkdir "fixtures/examples")
+               (("hspec\\s*>= 2.4.4   && < 2.6") "hspec")
+               (("QuickCheck\\s*\\^>= 2.11") "QuickCheck"))
              #t)))))
     (native-inputs
      `(("ghc-base-compat" ,ghc-base-compat)
diff --git a/gnu/packages/patches/ghc-haddock-library-unbundle.patch b/gnu/packages/patches/ghc-haddock-library-unbundle.patch
deleted file mode 100644
index 0e8b548956..0000000000
--- a/gnu/packages/patches/ghc-haddock-library-unbundle.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-This patch (inspired by Debian) allows ghc-haddock-library to use our
-ghc-attoparsec package instead of using a bundled version.
-
---- a/haddock-library.cabal	2018-09-01 01:22:18.676855884 -0400
-+++ b/haddock-library.cabal	2018-09-01 01:25:10.501150260 -0400
-@@ -10,7 +10,6 @@
-                       itself, see the ‘haddock’ package.
- license:              BSD3
- license-files:        LICENSE
--                      vendor/attoparsec-0.13.1.0/LICENSE
- maintainer:           Alex Biehl <alexbiehl@gmail.com>, Simon Hengel <sol@typeful.net>, Mateusz Kowalczyk <fuuzetsu@fuuzetsu.co.uk>
- homepage:             http://www.haskell.org/haddock/
- bug-reports:          https://github.com/haskell/haddock/issues
-@@ -28,7 +27,6 @@
-     , containers   >= 0.4.2.1 && < 0.6
-     , transformers >= 0.3.0   && < 0.6
- 
--  -- internal sub-lib
-   build-depends:        attoparsec
- 
-   hs-source-dirs:       src
-@@ -49,42 +47,6 @@
-   if impl(ghc >= 8.0)
-     ghc-options: -Wcompat -Wnoncanonical-monad-instances -Wnoncanonical-monadfail-instances
- 
--library attoparsec
--  default-language:     Haskell2010
--
--  build-depends:
--      base         >= 4.5     && < 4.12
--    , bytestring   >= 0.9.2.1 && < 0.11
--    , deepseq      >= 1.3     && < 1.5
--
--  hs-source-dirs:       vendor/attoparsec-0.13.1.0
--
--  -- NB: haddock-library needs only small part of lib:attoparsec
--  --     internally, so we only bundle that subset here
--  exposed-modules:
--    Data.Attoparsec.ByteString
--    Data.Attoparsec.ByteString.Char8
--    Data.Attoparsec.Combinator
--
--  other-modules:
--    Data.Attoparsec
--    Data.Attoparsec.ByteString.Buffer
--    Data.Attoparsec.ByteString.FastSet
--    Data.Attoparsec.ByteString.Internal
--    Data.Attoparsec.Internal
--    Data.Attoparsec.Internal.Fhthagn
--    Data.Attoparsec.Internal.Types
--    Data.Attoparsec.Number
--
--  ghc-options:          -funbox-strict-fields -Wall -fwarn-tabs -O2
--
--  ghc-options: -Wall
--  if impl(ghc >= 8.0)
--    ghc-options: -Wcompat -Wnoncanonical-monad-instances -Wnoncanonical-monadfail-instances
--  else
--    build-depends: semigroups ^>= 0.18.3, fail ^>= 4.9.0.0
--
--
- test-suite spec
-   type:             exitcode-stdio-1.0
-   default-language: Haskell2010
-@@ -115,11 +77,10 @@
-     , hspec         ^>= 2.4.4
-     , QuickCheck    ^>= 2.11
- 
--  -- internal sub-lib
-   build-depends: attoparsec
- 
-   -- Versions for the dependencies below are transitively pinned by
--  -- dependency on haddock-library:lib:attoparsec
-+  -- dependency on attoparsec
-   build-depends:
-       base
-     , bytestring
-@@ -146,7 +107,7 @@
-     haddock-library
- 
-   -- Versions for the dependencies below are transitively pinned by
--  -- dependency on haddock-library:lib:attoparsec
-+  -- dependency on attoparsec
-   build-depends:
-       base
-