summary refs log tree commit diff
diff options
context:
space:
mode:
authorGregor Giesen <giesen@zaehlwerk.net>2017-06-24 15:04:46 -0400
committerLeo Famulari <leo@famulari.name>2017-06-30 12:43:41 -0400
commit15f1d02aad963f9495f8441a0d2140e80ba719b6 (patch)
treefc78c4025375ec6dacd548caf07be0c3944fc6b7
parent5bc2d5798d8edb4690dbfda14f81f1688f1d2d29 (diff)
downloadguix-15f1d02aad963f9495f8441a0d2140e80ba719b6.tar.gz
gnu: Add libmatroska.
* gnu/packages/video.scm (libmatroska): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/video.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 816fb9dbea..04fce02df2 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -407,6 +407,34 @@ developed according to the official standards for DV video: IEC 61834 and
 SMPTE 314M.")
     (license license:lgpl2.1+)))
 
+(define-public libmatroska
+  (package
+    (name "libmatroska")
+    (version "1.4.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://dl.matroska.org/downloads/"
+                           name "/" name "-" version ".tar.bz2"))
+       (sha256
+        (base32
+         "1yi5cnv13nhl27xyqayd5l3sf0j3swfj3apzibv71yg9pariwi26"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libebml" ,libebml)))
+    (home-page "https://www.matroska.org")
+    (synopsis "C++ libary to parse Matroska files (.mkv and .mka)")
+    (description
+     "Matroska aims to become the standard of multimedia container formats.
+It is based on EBML (Extensible Binary Meta Language), a binary derivative
+of XML.  EBML enables the Matroska Development Team to gain significant
+advantages in terms of future format extensibility, without breaking file
+support in old parsers.
+libebml is a C++ library to read and write EBML files.")
+    (license license:lgpl2.1)))
+
 (define-public libva
   (package
     (name "libva")